lkml.org 
[lkml]   [2018]   [Dec]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v4 resend] firewire: Remove depends on HAS_DMA in case of platform dependency
On Dec 03 Geert Uytterhoeven wrote:
> Remove dependencies on HAS_DMA where a Kconfig symbol depends on another
> symbol that implies HAS_DMA, and, optionally, on "|| COMPILE_TEST".
> In most cases this other symbol is an architecture or platform specific
> symbol, or PCI.
>
> Generic symbols and drivers without platform dependencies keep their
> dependencies on HAS_DMA, to prevent compiling subsystems or drivers that
> cannot work anyway.
>
> This simplifies the dependencies, and allows to improve compile-testing.
>
> Signed-off-by: Geert Uytterhoeven <geert@linux-m68k.org>
> Reviewed-by: Mark Brown <broonie@kernel.org>
> Acked-by: Robin Murphy <robin.murphy@arm.com>

Thanks for resending. Applied to linux1394.git #for-next.

> ---
> v4:
> - Rebase to v4.18-rc1 (applies to next-20180622, too),
>
> v3:
> - Rebase to v4.17-rc1,
>
> v2:
> - Add Reviewed-by, Acked-by,
> - Drop RFC state,
> - Split per subsystem.
> ---
> drivers/firewire/Kconfig | 1 -
> 1 file changed, 1 deletion(-)
>
> diff --git a/drivers/firewire/Kconfig b/drivers/firewire/Kconfig
> index 145974f9662b63e6..4199849e37585181 100644
> --- a/drivers/firewire/Kconfig
> +++ b/drivers/firewire/Kconfig
> @@ -1,5 +1,4 @@
> menu "IEEE 1394 (FireWire) support"
> - depends on HAS_DMA
> depends on PCI || COMPILE_TEST
> # firewire-core does not depend on PCI but is
> # not useful without PCI controller driver

--
Stefan Richter
-======---=- ==-- ---==
http://arcgraph.de/sr/

\
 
 \ /
  Last update: 2018-12-03 18:58    [W:0.039 / U:3.636 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site