lkml.org 
[lkml]   [2018]   [Dec]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH] Revert "arm64: defconfig: Enable FSL_MC_BUS and FSL_MC_DPIO"
On Wed, Dec 19, 2018 at 11:18 AM Horia Geantă <horia.geanta@nxp.com> wrote:
>
> This reverts commit d9678adbe733a770428a98651beaa2817d503ed3.
>
> Received below report from Stefan.
> Revert the commit until CAAM driver dependency cycles are fixed.
>
> this patch in next-20181214 breaks "make modules_install" for
> arm64/defconfig on my Ubuntu machine:
>
> DEPMOD 4.20.0-rc6-next-20181214
> depmod: ERROR: Found 6 modules in dependency cycles!
> depmod: ERROR: Cycle detected: caamalg_desc -> dpaa2_caam -> authenc
> depmod: ERROR: Cycle detected: caamalg_desc -> dpaa2_caam -> fsl_mc_dpio
> depmod: ERROR: Cycle detected: dpaa2_caam -> caamhash_desc -> dpaa2_caam
> depmod: ERROR: Cycle detected: caamalg_desc -> dpaa2_caam -> caamhash_desc -> error
> depmod: ERROR: Cycle detected: caamalg_desc -> dpaa2_caam -> caamhash_desc -> caamalg_desc
>
> Reported-by: Stefan Wahren <stefan.wahren@i2se.com>
> Signed-off-by: Horia Geantă <horia.geanta@nxp.com>

I've applied the revert, but I think there is still a problem, since
anyone could manually enable those options and should not
see those cycles in the module dependencies.

Horia, can you have a look at what caused that and how to fix it?
It's probably a commit in the caam drivers. I have also created
a patch to address a problem with that driver but forgot
to send that out, it might fix this one as well, see my follow-up
patch "crypto: caam/qi2 - add a CRYPTO_DEV_FSL_CAAM
dependency".

Arnd

\
 
 \ /
  Last update: 2018-12-20 16:28    [W:0.069 / U:29.636 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site