lkml.org 
[lkml]   [2018]   [Dec]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [RESEND] PM / Domains: remove define_genpd_open_function() and define_genpd_debugfs_fops()
On Wed, 19 Dec 2018 at 10:17, Rafael J. Wysocki <rafael@kernel.org> wrote:
>
> On Wed, Dec 19, 2018 at 9:32 AM Greg Kroah-Hartman
> <gregkh@linuxfoundation.org> wrote:
> >
> > On Mon, Dec 17, 2018 at 09:19:07AM +0100, Ulf Hansson wrote:
> > > On Sat, 15 Dec 2018 at 09:45, Yangtao Li <tiny.windzz@gmail.com> wrote:
> > > >
> > > > We already have the DEFINE_SHOW_ATTRIBUTE, There is no need to define
> > > > such a macro, so remove define_genpd_open_function and
> > > > define_genpd_debugfs_fops.
> > > >
> > > > Convert them to DEFINE_SHOW_ATTRIBUTE.
> > > >
> > > > Signed-off-by: Yangtao Li <tiny.windzz@gmail.com>
> > > > ---
> > > > drivers/base/power/domain.c | 71 +++++++++++++------------------------
> > > > 1 file changed, 24 insertions(+), 47 deletions(-)
> > > >
> > > > diff --git a/drivers/base/power/domain.c b/drivers/base/power/domain.c
> > > > index 7f38a92b444a..10a61d6147d0 100644
> > > > --- a/drivers/base/power/domain.c
> > > > +++ b/drivers/base/power/domain.c
> > > > @@ -2671,7 +2671,7 @@ static int genpd_summary_one(struct seq_file *s,
> > > > return 0;
> > > > }
> > > >
> > > > -static int genpd_summary_show(struct seq_file *s, void *data)
> > > > +static int summary_show(struct seq_file *s, void *data)
> > >
> > > Why rename the function(s)?
> >
> > Because the macro requires it?
>
> Yeah.
>
> Ulf, this looks like a good cleanup to me, any objections to this one
> given the explanation above?

It looks good to me, I just didn't go into the details of how the
macro works. Now I know, so please add:

Acked-by: Ulf Hansson <ulf.hansson@linaro.org>

Kind regards
Uffe

\
 
 \ /
  Last update: 2018-12-19 10:21    [W:0.050 / U:15.908 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site