lkml.org 
[lkml]   [2018]   [Dec]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH v3 7/9] arm64: defconfig: Enable FSL_MC_BUS and FSL_MC_DPIO
Date
On 12/15/2018 11:44 PM, Stefan Wahren wrote:
> Hi,
>
>> Olof Johansson <olof@lixom.net> hat am 13. Dezember 2018 um 07:48 geschrieben:
>>
>>
>> On Fri, Nov 09, 2018 at 06:05:24AM +0000, Horia Geanta wrote:
>>> On 11/9/2018 3:11 AM, Marc Gonzalez wrote:
>>>> Commit e8342cc7954e ("enable CAAM crypto engine on QorIQ DPAA2 SoCs")
>>>> enabled CRYPTO_DEV_FSL_DPAA2_CAAM, which depends on FSL_MC_DPIO,
>>>> which is not set. Enable FSL_MC_BUS, and build FSL_MC_DPIO and
>>>> CRYPTO_DEV_FSL_DPAA2_CAAM as modules.
>>>>
>>>> Signed-off-by: Marc Gonzalez <marc.w.gonzalez@free.fr>
>>> Reviewed-by: Horia Geantă <horia.geanta@nxp.com>
>>
>> I had to redo this one, and when I did I noticed that there's also an ethernet
>> driver. Should that be enabled as well?
>>
>
> this patch in next-20181214 breaks "make modules_install" for arm64/defconfig on my Ubuntu machine:
>
> DEPMOD 4.20.0-rc6-next-20181214
> depmod: ERROR: Found 6 modules in dependency cycles!
> depmod: ERROR: Cycle detected: caamalg_desc -> dpaa2_caam -> authenc
> depmod: ERROR: Cycle detected: caamalg_desc -> dpaa2_caam -> fsl_mc_dpio
> depmod: ERROR: Cycle detected: dpaa2_caam -> caamhash_desc -> dpaa2_caam
> depmod: ERROR: Cycle detected: caamalg_desc -> dpaa2_caam -> caamhash_desc -> error
> depmod: ERROR: Cycle detected: caamalg_desc -> dpaa2_caam -> caamhash_desc -> caamalg_desc
>
> After reverting of this patch the issue disappeared.
>
Seems there's a dependency cycle b/w dpaa2_caam and caam{alg,hash}_desc, as follows:

A->B
---
dpaa2_caam needs cnstr_* exported by caam{alg,hash}_desc

B->A
---
caam{alg,hash}_desc need caam_imx, caam_little_end:
caam{hash,alg}_desc.c
--> desc_constr.h (included for descriptors generation functions)
--> regs.h (included for endianness helpers)
--> extern bool caam_imx, caam_little_end
caam_imx, caam_little_end are exported by dpaa2_caam - caamalg_qi2.c (when
CONFIG_CRYPTO_DEV_FSL_CAAM=n)

Could we drop this patch, until CAAM driver gets a proper fix (which is not
straightforward)?

Thanks,
Horia

\
 
 \ /
  Last update: 2018-12-17 16:34    [W:0.103 / U:2.464 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site