lkml.org 
[lkml]   [2018]   [Dec]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: [PATCH v1 2/2] usb:cdns3 Add Cadence USB3 DRD Driver
Date
Hi Peter

>On Mon, Dec 10, 2018 at 8:55 PM Pawel Laszczak <pawell@cadence.com> wrote:
>>
>> This patch introduce new Cadence USBSS DRD driver
>> to linux kernel.
>>
>> The Cadence USBSS DRD Driver is a highly
>> configurable IP Core which can be
>> instantiated as Dual-Role Device (DRD),
>> Peripheral Only and Host Only (XHCI)
>> configurations.
>>
>> The current driver has been validated with
>> FPGA burned. We have support for PCIe
>> bus, which is used on FPGA prototyping.
>>
>> The host side of USBSS-DRD controller is compliance
>> with XHCI specification, so it works with
>> standard XHCI linux driver.
>>
>> Signed-off-by: Pawel Laszczak <pawell@cadence.com>
>> ---
>
>I have compiled it at my ARM64 platform, and will give you more feedback after
>adding platform support. Below is one compile warning, please fix
>
> CC drivers/usb/cdns3/host.o
> AR drivers/usb/cdns3/cdns3-pci.o
>/home/b29397/work/projects/linux-imx/drivers/usb/cdns3/gadget.c: In
>function ‘cdns3_gadget_ep_disable’:
>/home/b29397/work/projects/linux-imx/drivers/usb/cdns3/gadget.c:1122:19:
>warning: ‘priv_dev’ may be used uninitialized in this function
>[-Wmaybe-uninitialized]
> dev_dbg(priv_dev->dev, "usbss: invalid parameters\n");
> ^~
> AR drivers/usb/cdns3/cdns3.o
>

I found this also. Some time ago I changed
pr_err("usbss: invalid parameters\n");
to
dev_err(priv_dev->dev, "usbss: invalid parameters\n");

In cdns3_gadget_ep_disable function and it was mistake.

I don't know why I didn't see this warning before posting patch.

Cheers
Pawel

\
 
 \ /
  Last update: 2018-12-16 14:03    [W:2.119 / U:0.164 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site