lkml.org 
[lkml]   [2018]   [Dec]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] acpi / apei: fix NULL deref during init
On Fri, Dec 14, 2018 at 11:54:28PM +0100, Borislav Petkov wrote:
> On Fri, Dec 14, 2018 at 11:42:01PM +0100, Thomas Schöbel-Theuer wrote:
> > Ah, I overlooked that commit e56c92565dfe2 is already providing a different
> > solution to the same problem in newer kernels _only_, as a _side_ effect
> > (not clear to me from the description, but clear from reading the code).
>
> Damn, I missed the fact that this is not the upstream kernel:
>
> CPU: 0 PID: 1 UID: 0 Comm: swapper/0 Not tainted 4.4.0-ui18344.004-uiabi1-infong-amd64 #1
>
> > So another alternative would be backporting e56c92565dfe2 to the 4.4 LTS
> > series. Also fine for me.
>
> That looks like the right fix.
>
> A note for the next time: do not send a fix for a stable kernel which is
> not upstream:
>
> >From Documentation/process/stable-kernel-rules.rst:
>
> " - It or an equivalent fix must already exist in Linus' tree (upstream)."
>
> The stable kernels track upstream so if a stable kernel has a problem,
> the first thing one needs to do is to check whether this has been fixed
> upstream and if so, to backport it. This is the case most of the time.
> In the very seldom cases where a separate fix is needed, it needs to be
> handled by asking Greg what to do. :-)
>
> Adding stable@ folks to CC to set me straight if I'm missing something.

Nope, you are correct, thanks!

greg k-h

\
 
 \ /
  Last update: 2018-12-15 09:06    [W:0.041 / U:20.368 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site