lkml.org 
[lkml]   [2018]   [Dec]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: A weird problem of Realtek r8168 after resume from S3
On Thu, Dec 13, 2018 at 10:20 AM Chris Chiu <chiu@endlessm.com> wrote:
>
> Hi,
> We got an acer laptop which has a problem with ethernet networking after
> resuming from S3. The ethernet is popular realtek r8168. The lspci shows as
> follows.
> 02:00.1 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd.
> RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 12)
>
> The problem is the ethernet is not accessible after resume. Pinging via
> ethernet always shows the response `Destination Host Unreachable`. However,
> the interesting part is, when I run tcpdump to monitor the problematic ethernet
> interface, the networking is back to alive. But it's dead again after
> I stop tcpdump.
> One more thing, if I ping the problematic machine from others, it achieves the
> same effect as above tcpdump. Maybe it's about the register setting for RX path?
>
> I tried the latest 4.20 rc version but the problem still there. I
> also tried some
> hw_reset or init thing in the resume path but no effect. Any
> suggestion for this?
> Thanks
>
> Chris

Gentle ping. Any additional information required?

Chris

\
 
 \ /
  Last update: 2018-12-14 04:34    [W:0.123 / U:0.008 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site