lkml.org 
[lkml]   [2018]   [Nov]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 7/9] arm64: defconfig: Drop CRYPTO_DEV_FSL_DPAA2_CAAM
Date
On 11/8/2018 3:23 PM, Marc Gonzalez wrote:
>
>
> On November 8, 2018 12:38:10 PM GMT+01:00, Horia Geanta <horia.geanta@nxp.com> wrote:
>> On 11/8/2018 1:23 PM, Horia Geanta wrote:
>>> On 11/7/2018 10:49 PM, Marc Gonzalez wrote:
>>>> [ Add interested parties ]
>>>>
>>>> On 07/11/2018 21:18, Marc Gonzalez wrote:
>>>>
>>>>> Commit e8342cc7954e ("enable CAAM crypto engine on QorIQ DPAA2
>> SoCs")
>>>>> enabled CRYPTO_DEV_FSL_DPAA2_CAAM, which depends on FSL_MC_DPIO,
>>>>> which is not set.
>>>>>
>>> Thanks Marc.
>>>
>>> Though I would prefer enabling the dependencies:
>>> dpaa2-caam driver -> dpio driver (FSL_MC_DPIO) -> fsl-mc driver
>> (FSL_MC_BUS).
>>>
>> Could you instead incorporate below patch in your series?
>> (I am pretty sure it won't apply clean)
>>
>> Thanks,
>> Horia
>>
>> -- >8 --
>>
>> Subject: [PATCH] arm64: defconfig: enable DPAA2 fsl-mc bus and DPIO
>> driver
>>
>> Enable fsl-mc bus and DPIO (Datapath I/O) driver, which are needed on
>> Layerscape SoCs with QorIQ Data Path Acceleration Architecture (DPAA)
>> v2.
>>
>> Suggested-by: Marc Gonzalez <marc.w.gonzalez@free.fr>
>> Signed-off-by: Horia Geantă <horia.geanta@nxp.com>
>> ---
>> arch/arm64/configs/defconfig | 2 ++
>> 1 file changed, 2 insertions(+)
>>
>> diff --git a/arch/arm64/configs/defconfig
>> b/arch/arm64/configs/defconfig
>> index c9a57d11330b..7c3785e61ef9 100644
>> --- a/arch/arm64/configs/defconfig
>> +++ b/arch/arm64/configs/defconfig
>> @@ -181,6 +181,7 @@ CONFIG_DMA_CMA=y
>> CONFIG_CMA_SIZE_MBYTES=32
>> CONFIG_HISILICON_LPC=y
>> CONFIG_SIMPLE_PM_BUS=y
>> +CONFIG_FSL_MC_BUS=y
>> CONFIG_MTD=y
>> CONFIG_MTD_BLOCK=y
>> CONFIG_MTD_M25P80=y
>> @@ -615,6 +616,7 @@ CONFIG_QCOM_IOMMU=y
>> CONFIG_RPMSG_QCOM_GLINK_RPM=y
>> CONFIG_RPMSG_QCOM_SMD=y
>> CONFIG_RASPBERRYPI_POWER=y
>> +CONFIG_FSL_MC_DPIO=y
>> CONFIG_QCOM_SMEM=y
>> CONFIG_QCOM_SMD_RPM=y
>> CONFIG_QCOM_SMP2P=y
>> --
>> 2.16.2
>
> Are CRYPTO_DEV_FSL_DPAA2_CAAM and CONFIG_FSL_MC_DPIO required to boot the platform? If not, we will build them as modules. I can send a v3 tonight with that change, as well as the various Acks.
>
No, the platform is able to boot without them, so I am ok with:
+CONFIG_FSL_MC_BUS=y
+CONFIG_FSL_MC_DPIO=m
-CONFIG_CRYPTO_DEV_FSL_DPAA2_CAAM=y
+CONFIG_CRYPTO_DEV_FSL_DPAA2_CAAM=m

Thanks,
Horia

\
 
 \ /
  Last update: 2018-11-08 16:52    [W:0.090 / U:2.772 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site