lkml.org 
[lkml]   [2018]   [Nov]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH 2/2] mm/sparse: add common helper to mark all memblocks present


On 2018-11-07 1:12 p.m., Andrew Morton wrote:
>> +void __init memblocks_present(void)
>> +{
>> + struct memblock_region *reg;
>> +
>> + for_each_memblock(memory, reg) {
>> + memory_present(memblock_get_region_node(reg),
>> + memblock_region_memory_base_pfn(reg),
>> + memblock_region_memory_end_pfn(reg));
>> + }
>> +}
>> +
>
> I don't like the name much. To me, memblocks_present means "are
> memblocks present" whereas this actually means "memblocks are present".
> But whatever. A little covering comment which describes what this
> does and why it does it would be nice.

The same argument can be made about the existing memory_present()
function and I think it's worth keeping the naming consistent. I'll add
a comment and resend shortly.

> Acked-by: Andrew Morton <akpm@linux-foundation.org>
>
> I can grab both patches and shall sneak them into 4.20-rcX, but feel
> free to merge them into some git tree if you'd prefer. If I see them
> turn up in linux-next I shall drop my copy.

Sounds good, thanks.

Logan

\
 
 \ /
  Last update: 2018-11-07 21:20    [W:0.083 / U:2.476 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site