[lkml]   [2018]   [Nov]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] block: respect virtual boundary mask in bvecs

>> How about changing that expression into the following to make it easier
>> for the compiler to optimize this code?
>> (offset | (bprv->bv_offset + bprv->bv_len)) & queue_virt_boundary(q)
> Uhm I have to admit I'm not really able to parse the above expression.
> Sure GCC will do it but I think it's less readable (at least for me).
> Let's see what other's think.

I personally not a huge fan of decoding complicated expressions. But if
others are fine with it then I am too...

 \ /
  Last update: 2018-11-07 04:31    [W:0.098 / U:1.988 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site