[lkml]   [2018]   [Nov]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [driver-core PATCH v7 2/9] driver core: Establish clear order of operations for deferred probe and remove
On Thu, Nov 29, 2018 at 10:07 AM Alexander Duyck
<> wrote:
> On Wed, 2018-11-28 at 17:57 -0800, Dan Williams wrote:
> > I think the flag should be named "cancel" and set it in the
> > device_del() path. Otherwise this is encoding code flow state in the
> > struct rather than device-state that the code needs to comprehend.
> Instead of "cancel" what would you think of "dead"? In my mind once we
> call device_del we are essentially working with a dead device object so
> that might make more sense in terms of a state rather than "cancel"
> which doesn't really tell us what should be canceled.

That sounds good to me.

> Looking over the code I could probably set it before we start calling
> the notifiers for BUS_NOTIFY_DEL_DEVICE. The only thing I am not sure
> about is if we would need to add any sort of synchronization primitives
> around it.

I think it needs to be something like a barrier:


...where you can be sure that anyone after that device_unlock() has
acted on dev->dead, or will see dev->dead.

 \ /
  Last update: 2018-11-29 19:56    [W:0.089 / U:12.668 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site