lkml.org 
[lkml]   [2018]   [Nov]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v9 01/13] x86/resctrl: Rename and move rdt files to new directory

* Borislav Petkov <bp@alien8.de> wrote:

> On Fri, Nov 23, 2018 at 08:28:39AM +0100, Ingo Molnar wrote:
> > Ugh, violent NAK on this unreadable directory naming: 'resctrl' is an
> > ugly double/triple abbreviation that nobody recognizes for what it is to
> > begin with, and even the long form 'resource control' is an overly
> > generic naming - *everything* the kernel does is in essence 'resource
> > control' ...
>
> Well, the fs this thing uses is called "resctrl".
>
> Documentation/x86/resctrl_ui.txt:1075:the resctrl will still mount but cannot create CTRL_MON directories.
> Documentation/x86/resctrl_ui.txt:1082:# mount -t resctrl resctrl /sys/fs/resctrl
> Documentation/x86/resctrl_ui.txt:1083:# cd /sys/fs/resctrl
>
> Are you saying that the fs should be renamed now too?

Sigh, probably not. I only noticed this naming snafu with the renaming
commit. The high level name was always RDT-ish - which while an acronym
is at least is a familiar high level name now with no obvious generic
namespace collision, while 'resctrl' less so.

> How are those *abbreviations* better? "hw_bw" is especially cryptic and
> the others are no better.

Those were suggestions - but I'd be fine with 'resource_control':

> "resctrl" to mean "resource control" is much better IMO.

Then at least make the directory name resource_control/, which is only
marginally longer and a lot more readable.

We really don't have to fit directly names into the 8 character DOS limit
anymore. ;-)

> [...] And it is different from the "other" resource controlling the
> kernel does because it is under arch/x86/kernel/cpu/ which tells you it
> is a *CPU* resource control.

Yeah, so this is not obvious from the filesystem name, nor does it excuse
the pointless abbreviation.

High level names matter.

Also, the Kconfig space, when it gets extended with the AMD bits, should
probably follow the same nomenclature: CONFIG_X86_CPU_RESOURCE_CONTROL=y
or such.

Ingo

\
 
 \ /
  Last update: 2018-11-23 09:42    [W:0.078 / U:1.140 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site