[lkml]   [2018]   [Nov]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 03/24] leds: dt-bindings: Add LED_FUNCTION definitions
On 11/11/2018 09:20 PM, Pavel Machek wrote:
> Hi!
>>>> +#define LED_FUNCTION_BACKLIGHT "backlight"
>>>> +#define LED_FUNCTION_BACKLIGHT_CLUSTER "backlight_cluster"
>>> Sounds like one of backlight and backlight_cluster should be deprecated?
>> I think so.
> Agreed.
>>>> +#define LED_FUNCTION_DEBUG "debug"
>>>> +#define LED_FUNCTION_DIA "dia"
>>> What does this one do?
>> I'd opt for something like "diagnostics", but this is a blind shot.
>> Let's remove it then and, and let people add more meaningful
>> definition in case it is needed.
>>>> +#define LED_FUNCTION_DISK "disk"
>>> We have disk, hd, hdd and sata. Deprecate some?
>> Disk should be the best choice, especially given that we have
>> identically named trigger.
> Ok.
>>>> +#define LED_FUNCTION_HD "hd"
>>>> +#define LED_FUNCTION_HDD "hdd"
>>>> +#define LED_FUNCTION_HDDERR "hdderr"
>>> Ok, I'll
>> Hmm?
> I was going to say that I'll bring it up in different email.
> I believe we should have disk:green:activity and disk:red:error, not
> "green:hdd" and "red:hdderr".

How would you propose to name the section corresponding to "disk",
if "function" is occupied by "activity"? Should it deserve a separate
DT property?

>>>> +#define LED_FUNCTION_HEALTH "health"
>>>> +#define LED_FUNCTION_HEARTBEAT "heartbeat"
>>> Sounds same as alive, deprecate alive?
>> Heartbeat may be designated specifically for registration
>> for events from the trigger with the same name.
> Ok. What is "alive" then?

Tells whether something is active or not?
In this case it seems to overlap with "pwr" probably.

>>>> +#define LED_FUNCTION_WIFI "wifi"
>>>> +#define LED_FUNCTION_WIRELESS "wireless"
>>>> +#define LED_FUNCTION_WLAN "wlan"
>>> Same as wifi and wireless, I guess, deprecate some?
>> I'd remove "wireless" and "wlan".
> Actually I'd keep wlan, but... :-).

It may depend of the regional preferences.

> We may want to do add some comments there, and sort it "most
> common/recommended first" or something.
> Best regards (and thanks for doing the work),

I'm doing it also for myself to avoid extra lines for
explaining the LED naming quirks every time a new driver
is submitted :-)

Best regards,
Jacek Anaszewski

 \ /
  Last update: 2018-11-11 22:17    [W:0.094 / U:0.680 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site