lkml.org 
[lkml]   [2018]   [Nov]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH] sched/rt: Introduce prio_{higher,lower}() helper for comparing RT task prority
Hi Peter,

Ingo Molnar <mingo@kernel.org> 于2018年11月12日周一 下午2:57写道:
>
>
> * Peter Zijlstra <peterz@infradead.org> wrote:
>
> > I think you only need the less thing, because:
> >
> > static inline bool prio_lower(int a, int b)
> > {
> > return a > b;
> > }
>
> I'd say that should be named rt_prio_lower(), even if it's local to
> sched/rt.c, right?
>

I agree with Ingo's point of view. Looks great. What is your opinion?
If you also agree. I will update the patch and send it.

Thanks.

\
 
 \ /
  Last update: 2018-11-12 16:16    [W:0.113 / U:0.328 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site