lkml.org 
[lkml]   [2018]   [Oct]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v2 01/11] arch/x86: Start renaming the rdt files to more generic names
From
Date
Hi Babu,

On 10/5/2018 1:55 PM, Moger, Babu wrote:
> New generation of AMD processors start support RDT(or QOS) features.
> With more than one vendors supporting these features, it seems more
> appropriate to rename these files.
>
> Signed-off-by: Babu Moger <babu.moger@amd.com>
> ---
> arch/x86/include/asm/{intel_rdt_sched.h => rdt_sched.h} | 0
> arch/x86/kernel/cpu/Makefile | 6 +++---
> arch/x86/kernel/cpu/{intel_rdt.c => rdt.c} | 4 ++--
> arch/x86/kernel/cpu/{intel_rdt.h => rdt.h} | 0
> .../cpu/{intel_rdt_ctrlmondata.c => rdt_ctrlmondata.c} | 2 +-
> arch/x86/kernel/cpu/{intel_rdt_monitor.c => rdt_monitor.c} | 2 +-
> .../cpu/{intel_rdt_pseudo_lock.c => rdt_pseudo_lock.c} | 6 +++---
> ...ntel_rdt_pseudo_lock_event.h => rdt_pseudo_lock_event.h} | 2 +-
> .../x86/kernel/cpu/{intel_rdt_rdtgroup.c => rdt_rdtgroup.c} | 4 ++--
> arch/x86/kernel/process_32.c | 2 +-
> arch/x86/kernel/process_64.c | 2 +-
> 11 files changed, 15 insertions(+), 15 deletions(-)
> rename arch/x86/include/asm/{intel_rdt_sched.h => rdt_sched.h} (100%)
> rename arch/x86/kernel/cpu/{intel_rdt.c => rdt.c} (99%)
> rename arch/x86/kernel/cpu/{intel_rdt.h => rdt.h} (100%)
> rename arch/x86/kernel/cpu/{intel_rdt_ctrlmondata.c => rdt_ctrlmondata.c} (99%)
> rename arch/x86/kernel/cpu/{intel_rdt_monitor.c => rdt_monitor.c} (99%)
> rename arch/x86/kernel/cpu/{intel_rdt_pseudo_lock.c => rdt_pseudo_lock.c} (99%)
> rename arch/x86/kernel/cpu/{intel_rdt_pseudo_lock_event.h => rdt_pseudo_lock_event.h} (95%)
> rename arch/x86/kernel/cpu/{intel_rdt_rdtgroup.c => rdt_rdtgroup.c} (99%)

During the RFC it was agreed that "resctrl" will be the neutral name and
"intel_rdt", "amd_qos", or "arm mpam" would be the vendor specific names.

It is ok to delay that renaming but I think any renaming done from this
point should respect this agreement.

For example, if you want to rename intel_rdt.c then please rename it to
resctrl.c instead of just rdt.c which does not represent a generic name
as expressed as a goal in the subject of this patch.

Reinette

\
 
 \ /
  Last update: 2018-10-09 18:40    [W:0.240 / U:2.192 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site