lkml.org 
[lkml]   [2018]   [Oct]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH] remove old GCC version implementation
Date
GCC 4.6 is the minimum supported now.

Signed-off-by: Mathieu Malaterre <malat@debian.org>
---
scripts/mod/file2alias.c | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)

diff --git a/scripts/mod/file2alias.c b/scripts/mod/file2alias.c
index 28a61665bb9c..4b59564d4706 100644
--- a/scripts/mod/file2alias.c
+++ b/scripts/mod/file2alias.c
@@ -83,11 +83,7 @@ extern struct devtable *__start___devtable[], *__stop___devtable[];
#endif /* __MACH__ */

#if !defined(__used)
-# if __GNUC__ == 3 && __GNUC_MINOR__ < 3
-# define __used __attribute__((__unused__))
-# else
-# define __used __attribute__((__used__))
-# endif
+#define __used __attribute__((__used__))
#endif

/* Define a variable f that holds the value of field f of struct devid
--
2.11.0
\
 
 \ /
  Last update: 2018-10-31 12:15    [W:0.047 / U:0.248 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site