[lkml]   [2018]   [Oct]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC PATCH v4 02/27] x86/fpu/xstate: Change some names to separate XSAVES system and user states
On 10/02/2018 09:21 AM, Yu-cheng Yu wrote:
> On Tue, 2018-10-02 at 17:29 +0200, Borislav Petkov wrote:
>> On Fri, Sep 21, 2018 at 08:03:26AM -0700, Yu-cheng Yu wrote:
>>> To support XSAVES system states, change some names to distinguish
>>> user and system states.
>> I don't understand what the logic here is. SDM says:
>> XSAVES—Save Processor Extended States Supervisor
>> the stress being on "Supervisor" - why does it need to be renamed to
>> "system" now?
> Good point. However, "system" is more indicative; CET states are per-task and
> not "Supervisor". Do we want to go back to "Supervisor" or add comments?

This is one of those things where the SDM language does not match what
we use in the kernel. I think it's fine to call them "system" or
"kernel" states to make it consistent with our existing in-kernel

I say add comments to clarify what the SDM calls it vs. what we do.

 \ /
  Last update: 2018-10-02 18:32    [W:0.064 / U:1.740 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site