lkml.org 
[lkml]   [2018]   [Oct]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH v2] slimbus: ngd: QCOM_QMI_HELPERS has to be selected
Date
QCOM_QMI_HELPERS is a hidden kconfig, so the proper usage is
to select it, not depend upon it.

Because of this change, we now also need to depend on the same
Kconfigs as QCOM_QMI_HELPERS depends on.

Signed-off-by: Niklas Cassel <niklas.cassel@linaro.org>
---
Hello Greg, Srini,

I'm sorry for this.
(Although I'm a bit curious why 0-day test bot didn't catch this.)

Considering that I've just changed QCOM_QMI_HELPERS in:
ccfb464cd106 ("soc: qcom: Allow COMPILE_TEST of qcom SoC Kconfigs")
which is currently in linux-next, and that this Kconfig should
depend on the same Kconfigs as QCOM_QMI_HELPERS depends on,
I chose to have this Kconfig match the QCOM_QMI_HELPERS that is
currently in linux-next.

drivers/slimbus/Kconfig | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/drivers/slimbus/Kconfig b/drivers/slimbus/Kconfig
index 9d73ad806698..8cd595148d17 100644
--- a/drivers/slimbus/Kconfig
+++ b/drivers/slimbus/Kconfig
@@ -22,8 +22,9 @@ config SLIM_QCOM_CTRL

config SLIM_QCOM_NGD_CTRL
tristate "Qualcomm SLIMbus Satellite Non-Generic Device Component"
- depends on QCOM_QMI_HELPERS
- depends on HAS_IOMEM && DMA_ENGINE
+ depends on HAS_IOMEM && DMA_ENGINE && NET
+ depends on ARCH_QCOM || COMPILE_TEST
+ select QCOM_QMI_HELPERS
help
Select driver if Qualcomm's SLIMbus Satellite Non-Generic Device
Component is programmed using Linux kernel.
--
2.17.2
\
 
 \ /
  Last update: 2018-10-15 21:45    [W:0.105 / U:1.388 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site