[lkml]   [2018]   [Jan]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v2] mm/swap.c: make functions and their kernel-doc agree
On Mon 29-01-18 16:43:55, Randy Dunlap wrote:
> From: Randy Dunlap <>
> Fix some basic kernel-doc notation in mm/swap.c:
> - for function lru_cache_add_anon(), make its kernel-doc function name
> match its function name and change colon to hyphen following the
> function name

This is pretty much an internal function to the MM. It shouldn't have
any external callers. Why do we need a kernel doc at all?

> - for function pagevec_lookup_entries(), change the function parameter
> name from nr_pages to nr_entries since that is more descriptive of
> what the parameter actually is and then it matches the kernel-doc
> comments also

I know what is nr_pages because I do expect pages to be returned. What
are entries? Can it be something different from pages?
Michal Hocko

 \ /
  Last update: 2018-01-30 13:34    [W:0.061 / U:16.100 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site