[lkml]   [2017]   [Sep]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v4 1/6] irqdomain: rename variables in irq_domain_{push,pop}_irq()
On 09/07/2017 05:47 AM, Marc Zyngier wrote:
> On 07/09/17 12:41, Masahiro Yamada wrote:
>> The meaning of "root" in irq_domain_{push,pop} is opposite to the
>> documentation. Documentation/IRQ-domain.txt depicts the hierarchy
>> IRQ domain as follows:
>> CPU Vector irq_domain (root irq_domain to manage CPU vectors)
>> ^
>> |
>> Interrupt Remapping irq_domain (manage irq_remapping entries)
>> ^
>> |
>> IOAPIC irq_domain (manage IOAPIC delivery entries/pins)
>> From above, the inner-most domain (nearest to the CPU) is "root".
>> The document also says, "When building irq_domain hierarchy, the
>> irq_domain near to the device is child and the irq_domain near to
>> CPU is parent." This is how irq_data->parent_data works. In
>> contrast, these function use a variable "child_irq_data" for that.
> The exact opposite argument could be used for the data structure. The
> irq_desc is the root of the list ordered with parent_data.
> Yes, this is confusing, but because we're using the same English words
> to describe two different things, we're bound to make one thing more
> difficult. I'm unconvinced that this change helps anything (it certainly
> confuses me more than anything else).

There may be room for improvement here.

Here is my recollection of how I choose the names:

"root" is the thing embedded in the struct irq_desc, if you think about
a typical linked list structure like this, we can refer to the starting
point as the "root". Sometimes it might be referred to as the "head" of
the list, but usually not the "tail"

"child" was used to indicate the thing we get to by traversing the link
in the list. The fact that ->parent is the name of the next pointer and
that it points to something called "child" is confusing here.

So what do I think should be done? This:

A) s/child_irq_data/parent_irq_data/g As this patch does, but leave
the root_irq_data name unchanged.

B) Change the name of the ->parent in struct irq_data to ->next

But that is just my $0.02

I fear we risk a Bike Shedding type of discussion here.

David Daney

> Thanks,
> M.

 \ /
  Last update: 2017-09-07 19:47    [W:0.081 / U:2.728 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site