[lkml]   [2017]   [Aug]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v2 0/3] livepatch: Introduce force sysfs attribute
On Thu, Aug 10, 2017 at 12:48:12PM +0200, Miroslav Benes wrote:
> Now there is a sysfs attribute called "force", which provides two
> functionalities, "signal" and "force" (previously "unmark"). I haven't
> managed to come up with better names. Proposals are welcome. On the
> other hand I do not mind it much.

Now "force" has two meanings, which is a little confusing. What do you
think about just having two separate write-only sysfs flags?

echo 1 > /sys/kernel/livepatch/signal
echo 1 > /sys/kernel/livepatch/force

That way there's no ambiguity.


 \ /
  Last update: 2017-08-11 23:11    [W:0.155 / U:0.924 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site