[lkml]   [2017]   [Aug]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v6 4/7] mm: refactoring TLB gathering API
Peter Zijlstra <> wrote:

> On Tue, Aug 01, 2017 at 05:08:15PM -0700, Nadav Amit wrote:
>> From: Minchan Kim <>
>> This patch is a preparatory patch for solving race problems caused by
>> TLB batch. For that, we will increase/decrease TLB flush pending count
>> of mm_struct whenever tlb_[gather|finish]_mmu is called.
>> Before making it simple, this patch separates architecture specific
>> part and rename it to arch_tlb_[gather|finish]_mmu and generic part
>> just calls it.
> I absolutely hate this. We should unify this stuff, not diverge it
> further.

Agreed, but I don’t see how this patch makes the situation any worse.

I’ll review your other comments by tomorrow due to some personal

 \ /
  Last update: 2017-08-11 19:13    [W:0.052 / U:0.032 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site