lkml.org 
[lkml]   [2017]   [Jul]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] printk: Modify operators of printed_len
From
Date
On Sat, 2017-07-08 at 04:32 +0800, pierre kuo wrote:
> hi Joe:

Hello Pierre.

> 2017-07-08 1:12 GMT+08:00 Joe Perches <joe@perches.com>:
> > On Sat, 2017-07-08 at 00:30 +0800, Pierre Kuo wrote:
> > > In 8b1742c9c207, we remove printk-recursion detection code in
> > > vprintk_emit(), where it is the first place that printed_len calculated.
> > > After removing above detection, it seems we can directly assign the
> > > result of log_output to printed_len.
> >
> > []
> > > diff --git a/kernel/printk/printk.c b/kernel/printk/printk.c
> >
> > []
> > > @@ -1754,7 +1754,7 @@ asmlinkage int vprintk_emit(int facility, int level,
> > > if (dict)
> > > lflags |= LOG_PREFIX|LOG_NEWLINE;
> > >
> > > - printed_len += log_output(facility, level, lflags, dict, dictlen, text, text_len);
> > > + printed_len = log_output(facility, level, lflags, dict, dictlen, text, text_len);
> >
> > If this is appropriate, this should also remove the
> > initialization of printed_len and perhaps rename it too.
>
> I cannot quite understand the reason why need to rename.
> printed_len seems meet the meaning we expect for here.

Verbosity. To me, len would be adequate.

Anyway, the real point was the declaration of printed_len could
remove the " = 0" as it's now only set once.

cheers, Joe

\
 
 \ /
  Last update: 2017-07-08 01:04    [W:0.259 / U:0.024 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site