lkml.org 
[lkml]   [2017]   [Jul]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH V1 2/5] spmi: pmic-arb: rename pa_xx to pmic_arb_xx and other code cleanup
On 2017-07-06 12:19, Stephen Boyd wrote:
> On 07/03, Kiran Gunda wrote:
>> This patch cleans up the following.
>>
>> - Rename the "pa" to "pmic_arb".
>> - Rename the spmi_pmic_arb *dev to spmi_pmic_arb *pmic_arb.
>> - Rename the pa_{read,write}_data() functions to
>> pmic_arb_{read,write}_data().
>> - Rename channel to APID.
>> - Rename the HWIRQ_*() macros to hwirq_to_*().
>> - Clean up qpnpint_irq_set_type() and pmic_arb_find_apid()
>> functions.
>>
>> Signed-off-by: Kiran Gunda <kgunda@codeaurora.org>
>> ---
>> drivers/spmi/spmi-pmic-arb.c | 454
>> +++++++++++++++++++++----------------------
>> 1 file changed, 227 insertions(+), 227 deletions(-)
>>
>
> This patch is large and noisy. Have you tried running
> scripts/objdiff on this to make sure nothing changed?
The objdiff will not be helpful here as this patch is for
the renaming and clean-up to address your multiple minor
comments on the earlier patches, which has minor code changes.

I have keenly checked the patch and made sure that there are no
unintended changes, except (+ * v2 only.) one extra line in
documentation of struct apid_data {. I will remove this and
upload the next patch.

\
 
 \ /
  Last update: 2017-07-07 16:50    [W:0.043 / U:4.020 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site