lkml.org 
[lkml]   [2017]   [Jun]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH RFC 02/26] task_work: Replace spin_unlock_wait() with lock/unlock pair
On Fri, Jun 30, 2017 at 05:20:10PM +0200, Oleg Nesterov wrote:
> On 06/30, Paul E. McKenney wrote:
> >
> > > > + raw_spin_lock_irq(&task->pi_lock);
> > > > + raw_spin_unlock_irq(&task->pi_lock);
> >
> > I agree that the spin_unlock_wait() implementations would avoid the
> > deadlock with an acquisition from an interrupt handler, while also
> > avoiding the need to momentarily disable interrupts. The ->pi_lock is
> > a per-task lock, so I am assuming (perhaps naively) that contention is
> > not a problem. So is the overhead of interrupt disabling likely to be
> > noticeable here?
>
> I do not think the overhead will be noticeable in this particular case.
>
> But I am not sure I understand why do we want to unlock_wait. Yes I agree,
> it has some problems, but still...
>
> The code above looks strange for me. If we are going to repeat this pattern
> the perhaps we should add a helper for lock+unlock and name it unlock_wait2 ;)
>
> If not, we should probably change this code more:

This looks -much- better than my patch! May I have your Signed-off-by?

Thanx, Paul

> --- a/kernel/task_work.c
> +++ b/kernel/task_work.c
> @@ -96,20 +96,16 @@ void task_work_run(void)
> * work->func() can do task_work_add(), do not set
> * work_exited unless the list is empty.
> */
> + raw_spin_lock_irq(&task->pi_lock);
> do {
> work = READ_ONCE(task->task_works);
> head = !work && (task->flags & PF_EXITING) ?
> &work_exited : NULL;
> } while (cmpxchg(&task->task_works, work, head) != work);
> + raw_spin_unlock_irq(&task->pi_lock);
>
> if (!work)
> break;
> - /*
> - * Synchronize with task_work_cancel(). It can't remove
> - * the first entry == work, cmpxchg(task_works) should
> - * fail, but it can play with *work and other entries.
> - */
> - raw_spin_unlock_wait(&task->pi_lock);
>
> do {
> next = work->next;
>
> performance-wise this is almost the same, and if we do not really care about
> overhead we can simplify the code: this way it is obvious that we can't race
> with task_work_cancel().
>
> Oleg.
>

\
 
 \ /
  Last update: 2017-06-30 23:14    [W:0.219 / U:0.872 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site