lkml.org 
[lkml]   [2017]   [Nov]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v6 04/11] x86: define IA32_FEATUE_CONTROL.SGX_LC
On Tue, Nov 28, 2017 at 02:00:03PM -0800, Sean Christopherson wrote:
> What about SGX_LC_ENABLE?  The title in the MSR section of the SDM is
> "SGX Launch Control Enable", and it's more consistent with the other
> bits defined in feature control.  I'd also prefer that name for the
> actual #define too, SGX_LAUNCH_CONTROL_ENABLE is overly verbose IMO.

This is a bit ugly name but it is also very clear:

FEATURE_CONTROL_SGX_LEPUBKEYHASH_WRITE_ENABLE

Just pushed update to the le branch. SGX_LC_ENABLE is a nice short name
but it does not reflect the semantics.

Maybe we could combine these and name it as

FEATURE_CONTROL_SGX_LC_WRITE_ENABLE

It is not as ugly and is very clear what it does.

/Jarkko

\
 
 \ /
  Last update: 2017-11-28 23:22    [W:0.153 / U:4.920 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site