[lkml]   [2017]   [Oct]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] vmalloc: add __alloc_vm_area() for optimizing vmap stack
This looks fine in general, but a few comments:

- can you split adding the new function from switching over the fork
- at least kasan and vmalloc_user/vmalloc_32_user use very similar
patterns, can you switch them over as well?
- the new __alloc_vm_area looks very different from alloc_vm_area,
maybe it needs a better name? vmalloc_range_area for example?
- when you split an existing function please keep the more low-level
function on top of the higher level one that calls it.

 \ /
  Last update: 2017-10-08 11:18    [W:0.061 / U:2.340 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site