lkml.org 
[lkml]   [2017]   [Oct]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] kbuild: comments cleanup in Makefile.lib
From
Date
Masahiro-san,

On 10/04/2017 12:58 PM, Masahiro Yamada wrote:
> Hi Cao,
>
>
> 2017-09-19 20:36 GMT+09:00 Cao jin <caoj.fnst@cn.fujitsu.com>:
>> It has:
>> 1. Move comments close to what it want to comment.
>> 2. Comments cleanup & improvement.
>>
>> Signed-off-by: Cao jin <caoj.fnst@cn.fujitsu.com>


>>
>> -# if $(foo-objs) exists, foo.o is a composite object
>> +# if $(foo-objs) or $(foo-y) or $(foo-m) exists, foo.o is a composite object
>
>
> Nit:
>
> "if $(foo-objs), $(foo-y), or $(foo-m) exists" will be better.
>

Yes, true.

>> multi-used-y := $(sort $(foreach m,$(obj-y), $(if $(strip $($(m:.o=-objs)) $($(m:.o=-y))), $(m))))
>> multi-used-m := $(sort $(foreach m,$(obj-m), $(if $(strip $($(m:.o=-objs)) $($(m:.o=-y)) $($(m:.o=-m))), $(m))))
>> multi-used := $(multi-used-y) $(multi-used-m)
>> @@ -90,7 +84,6 @@ subdir-ym := $(addprefix $(obj)/,$(subdir-ym))
>> obj-dirs := $(addprefix $(obj)/,$(obj-dirs))
>>
>> # These flags are needed for modversions and compiling, so we define them here
>> -# already
>> # $(modname_flags) #defines KBUILD_MODNAME as the name of the module it will
>
>
> I am not sure if "#defines" is intentional or not.
> I think "#" is unnecessary.
>

Yes, agree with you

--
Sincerely,
Cao jin


\
 
 \ /
  Last update: 2017-10-09 05:44    [W:0.057 / U:2.404 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site