[lkml]   [2016]   [Sep]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC/RFT][PATCH v2 0/7] Functional dependencies between devices
On Wed, Sep 14, 2016 at 12:41:33AM +0200, Rafael J. Wysocki wrote:
> On Tuesday, September 13, 2016 11:58:56 AM Marek Szyprowski wrote:
> > Rafael, BTW, didn't you plan to change the name of the device_link_add()
> > function to device_dependency_add() to avoid confusion with network device
> > "link"?
> I was concerned about the "devlink" name in particular, but I thought that
> struct device_link would be distinct enough. If not, I can still change it.

The "links" term has already been established, in a sense, by commit
5063ce1571b7 ("PM / Domains: Allow generic PM domains to have multiple

However the genpd links introduced by that commit use a master/slave
terminology, rather than supplier/consumer.

Best regards,


 \ /
  Last update: 2016-09-18 13:23    [W:0.084 / U:0.388 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site