lkml.org 
[lkml]   [2016]   [Sep]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [BISECTED REGRESSION] v4.8-rc: gpio-leds broken on OCTEON
From
Date
Hi! On 25.08.2016 20:24, Aaro Koskinen wrote:
> On Wed, Aug 24, 2016 at 11:42:00AM -0500, Steven J. Hill wrote:
>> It is actually two patches that cause the breakage. The other is:
>> commit e55aeb6ba4e8cc3549bff1e75ea1d029324bce21
>> of/irq: Mark interrupt controllers as populated before initialisation
>> I needed to revert both of these in order to get MMC working on our 71xx and
>> 78xx boards. For our MMC, I got error messages from the MMC core of "Invalid
>> POWER GPIO" until I applied the second patch. I will have a fix worthy of
>> upstreaming today which will be posted today.
>
> The below change works for me...
>
> diff --git a/arch/mips/cavium-octeon/octeon-irq.c b/arch/mips/cavium-octeon/octeon-irq.c
> index 5a9b87b..5fd57c2 100644
> --- a/arch/mips/cavium-octeon/octeon-irq.c
> +++ b/arch/mips/cavium-octeon/octeon-irq.c
> @@ -1618,6 +1618,7 @@ static int __init octeon_irq_init_gpio(
> pr_warn("Cannot allocate memory for GPIO irq_domain.\n");
> return -ENOMEM;
> }
> + of_node_clear_flag(gpio_node, OF_POPULATED);
>
> return 0;
> }

This afaics wasn't merged and the discussion looks stalled. Was this
issue discussed elsewhere or even fixed in between? Just asking, because
this issue is on the list of regressions for 4.8.

Ciao, Thorsten

\
 
 \ /
  Last update: 2016-09-17 09:59    [W:0.040 / U:0.788 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site