lkml.org 
[lkml]   [2016]   [Sep]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] extcon: Introduce EXTCON_PROP_DISP_HPD property
Hi Guenter,

On 2016년 09월 12일 11:29, Guenter Roeck wrote:
> On Sun, Sep 11, 2016 at 7:23 PM, Chanwoo Choi <cw00.choi@samsung.com> wrote:
>> Hi Chris,
>>
>> On 2016년 09월 12일 10:03, Chanwoo Choi wrote:
>>> Hi Chris,
>>>
>>> On 2016년 09월 10일 09:33, Chris Zhong wrote:
>>>> EXTCON_PROP_DISP_HPD is need by display port, if the system has no hpd
>>>> interrupt, this property can be used.
>>>
>>> What is meaning of HPD? So, you need to add the
>>> description and reference for HPD in commit message.
>>>
>>> For example,
>>> When adding EXTCON_PROP_USB_SS property[1],
>>> the commit message included the reference for USB SuperSpeed.
>>> [1] https://git.kernel.org/cgit/linux/kernel/git/chanwoo/extcon.git/commit/?h=extcon-next&id=8457a1b49a2af0a0e71f80afed9f7c80de361610
>>>
>>>>
>>>> Change-Id: I8b3eb78429126eaa369b10711b7f857b0a3df8ed
>>>
>>> You have to remove the 'Change-Id'.
>>>
>>>> Signed-off-by: Chris Zhong <zyw@rock-chips.com>
>>>> ---
>>>> include/linux/extcon.h | 14 +++++++++++++-
>>>> 1 file changed, 13 insertions(+), 1 deletion(-)
>>>>
>>>> diff --git a/include/linux/extcon.h b/include/linux/extcon.h
>>>> index 9147c42..4411893 100644
>>>> --- a/include/linux/extcon.h
>>>> +++ b/include/linux/extcon.h
>>>> @@ -131,9 +131,21 @@
>>>> #define EXTCON_PROP_JACK_MAX 100
>>>> #define EXTCON_PROP_JACK_CNT (EXTCON_PROP_JACK_MAX - EXTCON_PROP_JACK_MIN + 1)
>>>>
>>>> +/*
>>>> + * Properties of EXTCON_TYPE_DISP.
>>>> + *
>>>> + * - EXTCON_PROP_DISP_HPD
>>>
>>> You should add the full name of 'HPD'.
>>
>> On previous mail, I replied ambiguous comment.
>>
>> I mean that you better to add the property name with full name as following:
>>
>> EXTCON_PROP_DISP_HPD ( Hxxx Pxxx Dxxx)
>
> What do you prefer ?
>
> HOTPLUGDETECT ? HOT_PLUG_DETECT ? HOTPLUG_DETECT ?

I prefer to add 'HPD (Hot Plug Detect)'.

>
> The term "HPD" seems to be quite common in the DisplayPort world; in
> most presentations it isn't even explained. Personally I would prefer
> to stick with HPD and explain it in the comments.

People who are unfamiliar with DisplayPort world
need the explanation and full name of HPD.
Basically, all abbreviation should show the full name.

--
Best Regards,
Chanwoo Choi

\
 
 \ /
  Last update: 2016-09-17 09:59    [W:0.167 / U:0.720 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site