[lkml]   [2016]   [Oct]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v4 2/2] fpga: Add support for Lattice iCE40 FPGAs
On Mon, Oct 31, 2016 at 11:58 AM, Joel Holdsworth
<> wrote:
> Hi Rob,
> Thanks for taking the time review the patches.
>>> .../bindings/fpga/lattice-ice40-fpga-mgr.txt | 23 +++
>> It's preferred that bindings are a separate patch.
> Can you just clarify a little? I'm happy to split the patch up, but I don't
> understand how it could work without the bindings. For example, in
> ice40_fpga_probe, I have to get the GPIOs with devm_gpiod_get for the driver
> to work.
> Maybe I'm missing something. Or do you just mean the documentation?

Yes, just the documentation.


>>> +- creset_b-gpio: GPIO connected to CRESET_B pin. Note that
>>> CRESET_B is
>> Don't use '_'. In this case, I'd just do cresetb-gpios.
> So the pin is called CRESET_B in the datasheet. I think the _B refers to the
> active-low polarity of the line.
> So I would think it should be creset-b-gpios or creset-gpios. I'm not so
> convinced cresetb-gpios is ideal, but it's a minor point.
>>> + treated as an active-low output because the
>>> signal is
>>> + treated as an enable signal, rather than a reset.
>>> This
>> Though for enable signals, enable-gpios is fairly standard even if that
>> deviates from the pin name.
> I would think that would just confuse the user, unless they dig out the
> binding docs. The FPGA doesn't have an enable pin, and it's not at all
> obvious that a "reset" pin means "enable" in this driver.
> Again, if you're adamant this is the correct convention it's no problem to
> make the change - just seems weird to me. What do you think?

"reset-gpios" is also somewhat standard if you prefer. You're the one
that called it an enable. :)


 \ /
  Last update: 2016-10-31 22:22    [W:1.030 / U:0.912 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site