[lkml]   [2016]   [Oct]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [x86] 811565123a: BUG: kernel hang in early-boot stage, last printk: Probing EDD (edd=off to disable)... ok
On Sat, Oct 01, 2016 at 10:59:38AM +0800, kernel test robot wrote:
> FYI, we noticed the following commit:
> Andi-Kleen/x86-Report-Intel-platform_id-in-proc-cpuinfo/20160924-100841
> commit 811565123a194d9cc0b490719bef761e1730dbf4 ("x86: Report Intel platform_id in /proc/cpuinfo")
> in testcase: boot
> on test machine: qemu-system-x86_64 -enable-kvm -m 320M
> caused below changes:

I tried to reproduce this, but can't. If I use the config with qemu it
boots until it panics for missing root file system.

The most likely cause would be the RDMSR failing.

Your config doesn't have the Intel microcode driver enabled.

With the change the MSR read will be done unconditional
(because I moved it to generic x86 code). But that should
have worked anyways because when the microcode driver is enabled
it would do the same thing. Also KVM supports this MSR, it
is in the code for single git has history.

So it is puzzling why it is failing.


Could you do two tests for me:

- Enable CONFIG_MICROCODE_INTEL and see if it boots then

- Add CONFIG_DEBUG_INFO to the config.
Add -s to the qemu command line and boot again. Then when it hangs
connect gdb to see where it hangs

gdb -ex "target remote localhost:1234" vmlinux

<show output>


 \ /
  Last update: 2016-10-03 23:28    [W:0.072 / U:0.716 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site