lkml.org 
[lkml]   [2016]   [Oct]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v3] kprobes: unpoison stack in jprobe_return() for KASAN
On Fri, Oct 14, 2016 at 1:25 PM, Will Deacon <will.deacon@arm.com> wrote:
> On Fri, Oct 14, 2016 at 12:53:56PM +0200, Dmitry Vyukov wrote:
>> KASAN stack instrumentation poisons stack redzones on function entry
>> and unpoisons them on function exit. If a function exits abnormally
>> (e.g. with a longjmp like jprobe_return()), stack redzones are left
>> poisoned. Later this leads to random KASAN false reports.
>>
>> Unpoison stack redzones in the frames we are going to jump over
>> before doing actual longjmp in jprobe_return().
>>
>> Signed-off-by: Dmitry Vyukov <dvyukov@google.com>
>> Cc: Mark Rutland <mark.rutland@arm.com>
>> Cc: Catalin Marinas <catalin.marinas@arm.com>
>> Cc: Andrey Ryabinin <ryabinin.a.a@gmail.com>
>> Cc: Lorenzo Pieralisi <lorenzo.pieralisi@arm.com>
>> Cc: Alexander Potapenko <glider@google.com>
>> Cc: Will Deacon <will.deacon@arm.com>
>> Cc: Ingo Molnar <mingo@kernel.org>
>> Cc: Andrew Morton <akpm@linux-foundation.org>
>> Cc: Thomas Gleixner <tglx@linutronix.de>
>> Cc: "H. Peter Anvin" <hpa@zytor.com>
>> Cc: Ananth N Mavinakayanahalli <ananth@linux.vnet.ibm.com>
>> Cc: Anil S Keshavamurthy <anil.s.keshavamurthy@intel.com>
>> Cc: "David S. Miller" <davem@davemloft.net>
>> Cc: Masami Hiramatsu <mhiramat@kernel.org>
>> Cc: x86@kernel.org
>> Cc: kasan-dev@googlegroups.com
>>
>> --
>>
>> Changes since v1:
>> - leave kasan_unpoison_remaining_stack() intact
>> - instead add kasan_unpoison_stack_above_sp_to()
>> - rename kasan_unpoison_remaining_stack() to kasan_unpoison_task_stack_below()
>>
>> Changes since v2:
>> - fix build by adding return type to kasan_unpoison_stack_above_sp_to
>> (tested v2 with it, but forgot to git add)
>
> I get build warnings with this patch applied and KASAN enabled:
>
> mm/kasan/kasan.c: In function ‘kasan_unpoison_task_stack_below’:
> mm/kasan/kasan.c:82:34: warning: passing argument 2 of ‘__kasan_unpoison_stack’ discards ‘const’ qualifier from pointer target type [-Wdiscarded-qualifiers]
> __kasan_unpoison_stack(current, watermark);
> ^~~~~~~~~
> mm/kasan/kasan.c:65:13: note: expected ‘void *’ but argument is of type ‘const void *’
> static void __kasan_unpoison_stack(struct task_struct *task, void *sp)
> ^~~~~~~~~~~~~~~~~~~~~~
> mm/kasan/kasan.c: In function ‘kasan_unpoison_stack_above_sp_to’:
> mm/kasan/kasan.c:92:27: error: called object ‘current_stack_pointer’ is not a function or function pointer
> const void *sp = (void *)current_stack_pointer();
> ^~~~~~~~~~~~~~~~~~~~~


Mailed v4.

Thanks

\
 
 \ /
  Last update: 2016-10-14 13:56    [W:0.048 / U:1.952 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site