lkml.org 
[lkml]   [2015]   [Apr]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: Unreliable hibernation on Lenovo x230 (regression)
Date
On Friday, April 03, 2015 05:58:25 PM rhn wrote:
> On Thu, 2 Apr 2015 17:28:05 +0200
> Pavel Machek <pavel@ucw.cz> wrote:
>
> > On Wed 2015-04-01 21:47:43, rhn wrote:
> > > Hello,
> > >
> > > Between kernel 3.16 and 3.17, a regression has been introduced where the first hibernation after regular shutdown always fails to resume. Subsequent hibernations succeed.
> > >
> > > The system is a Lenovo x230 with Intel i5, booting with EFI, with the hibernate partition located on a secondary SSD drive. Installed system is Fedora 20, hibernation and reboots were issued using the KDE shutdown dialog.
> > >
> > > I have tracked the problem to first appear in the commit
> > > e67ee10190e69332f929bdd6594a312363321a66 Merge branches 'pm-sleep', 'pm-cpufreq' and 'pm-cpuidle'
> > >
> > > The problem itself manifests in dmesg as follows (system was first
> > > restarted, then hibernated - this log is from the subsequent
> > resume):
> >
> > Ok, can you try to disable cpufreq and cpuidle, and then try if it
> > reproduces?
> >
> > At that point, this is the candidate:
> >
> > commit e67ee10190e69332f929bdd6594a312363321a66
> > Merge: 21c806d 84c91b7 39c8bba 372ba8c
> > Author: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
> > Date: Mon Aug 11 23:19:48 2014 +0200
> >
> > Merge branches 'pm-sleep', 'pm-cpufreq' and 'pm-cpuidle'
> >
> > * pm-sleep:
> > PM / hibernate: avoid unsafe pages in e820 reserved regions
> >
> > ...
> > Alternatively, you can just try to revert
> >
> > commit 84c91b7ae07c62cf6dee7fde3277f4be21331f85
> > Author: Lee, Chun-Yi <joeyli.kernel@gmail.com>
> > Date: Mon Aug 4 23:23:21 2014 +0800
> >
> > PM / hibernate: avoid unsafe pages in e820 reserved regions
> >
> > When the machine doesn't well handle the e820 persistent when
> > hibernate
> > resuming, then it may cause page fault when writing image to
> > snapshot
> > buffer:
> >
> >
> > ...
> >
> > Thanks,
> > Pavel
>
> I tried to disable CONFIG_CPU_IDLE and CONFIG_CPU_FREQ, however for some reason I could only disable CONFIG_CPU_FREQ.
>
> The bug persisted.
>
> Reverting the commit 84c91b7 on top of e67ee10 fixes the problem.
>
> I created a copy of the bug report here: https://bugzilla.kernel.org/show_bug.cgi?id=96111

Please check if 4.0-rc6 still has the problem and if reverting the commit in
question on top of it fixes the problem too.


--
I speak only for myself.
Rafael J. Wysocki, Intel Open Source Technology Center.


\
 
 \ /
  Last update: 2015-04-03 23:41    [W:0.119 / U:0.124 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site