lkml.org 
[lkml]   [2015]   [Mar]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: randconfig build error with next-20150303, in drivers/bcma/driver_pcie2.c
From
On Thu, Mar 5, 2015 at 6:44 AM, Kalle Valo <kvalo@codeaurora.org> wrote:
> Stephen Rothwell <sfr@canb.auug.org.au> writes:
>
>> Hi Kalle,
>>
>> On Wed, 04 Mar 2015 16:31:00 +0200 Kalle Valo <kvalo@codeaurora.org> wrote:
>>>
>>> Jim Davis <jim.epost@gmail.com> writes:
>>>
>>> > Building with the attached random configuration file,
>>> >
>>> > drivers/bcma/driver_pcie2.c: In function 'bcma_core_pcie2_up':
>>> > drivers/bcma/driver_pcie2.c:196:2: error: implicit declaration of
>>> > function 'pcie_set_readrq' [-Werror=implicit-function-declaration]
>>> > err = pcie_set_readrq(dev, pcie2->reqsize);
>>> > ^
>>>
>>> This should fix it:
>>>
>>> bcma: add missing includes
>>>
>>> https://git.kernel.org/cgit/linux/kernel/git/kvalo/wireless-drivers-next.git/commit/?id=2264fc857decd45798368f46861d9aecac23546f
>>
>> However, that commit is in next-20150304 and we still get the error
>> (see, for example,
>> http://kisskb.ellerman.id.au/kisskb/buildresult/12376688/).
>
> I applied few fixes from Rafal and Chen:
>
> 1ca2760fb2c1 bcma: prepare Kconfig symbol for PCI driver
> 0a4e699a41f7 bcma: move internal function declarations to private header
> c32ec2a11321 bcma: make bcma_host_pci_(up|down) calls safe for every config
> b09f5ec18b16 bcma: Kconfig: Let it depend on PCI
>
> It would be great if someone could report if the build errors are gone
> now.

I reran that configuration file on
wireless-drivers-next-for-davem-2015-02-07-9274-g1ca2760fb2c13, with
no build errors.


\
 
 \ /
  Last update: 2015-03-05 18:21    [W:0.059 / U:0.068 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site