lkml.org 
[lkml]   [2015]   [Mar]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: [PATCH 61/86] scsi/qla1280: use uapi/linux/pci_ids.h directly
    From
    Date
    On Sun, 2015-03-29 at 15:42 +0200, Michael S. Tsirkin wrote:
    > Header moved from linux/pci_ids.h to uapi/linux/pci_ids.h,
    > use the new header directly so we can drop
    > the wrapper in include/linux/pci_ids.h.
    >
    > Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
    > ---
    > drivers/scsi/qla1280.c | 2 +-
    > 1 file changed, 1 insertion(+), 1 deletion(-)
    >
    > diff --git a/drivers/scsi/qla1280.c b/drivers/scsi/qla1280.c
    > index c68a66e..b2ada21 100644
    > --- a/drivers/scsi/qla1280.c
    > +++ b/drivers/scsi/qla1280.c
    > @@ -348,7 +348,7 @@
    > #include <linux/pci.h>
    > #include <linux/proc_fs.h>
    > #include <linux/stat.h>
    > -#include <linux/pci_ids.h>
    > +#include <uapi/linux/pci_ids.h>

    This is bogus, isn't it? There's a -Iuapi somewhere in the kernel
    compile line so the original include is still valid. Zorro does this:
    zorro_ids.h is exclusively in uapi but the include is still

    #include <linux/zorro_ids.h>

    James




    \
     
     \ /
      Last update: 2015-03-29 16:41    [W:2.306 / U:0.744 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site