lkml.org 
[lkml]   [2014]   [Dec]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: iwlwifi-driver card doesn't work with 3.19-rc2+
Date
On Tue, 2014-12-30 at 16:21 +0100, Jiri Kosina wrote:
> On Tue, 30 Dec 2014, Grumbach, Emmanuel wrote:
>
> > > > So why do you used them?
> > > > They have been deprecated for a couple of years now. You should be
> > > > using nl80211 based tools such as iw.
> > >
> > > A couple of years is not very long where userspace is concerned.
> > >
> > Well - the decently new wireless tools do talk nl80211.
>
> With 3.18-rc5, I get this:
>
> # iwconfig --version
> iwconfig Wireless-Tools version 30
> Compatible with Wireless Extension v11 to v22.
>
> Kernel Currently compiled with Wireless Extension v22.
>
> wlan0 Recommend Wireless Extension v21 or later,
> Currently compiled with Wireless Extension v22.
>
>
> With 3.19-rc, I get (with the same userspace) this:
>
> # iwconfig --version
> iwconfig Wireless-Tools version 30
> Compatible with Wireless Extension v11 to v22.
>
> Cannot read /proc/net/wireless
>
> And nothing else (iwlist, etc) works either. This is with
>
> # rpm -qi wireless-tools | grep Ver
> Version : 30.pre9
>
> from openSUSE 13.2. That's not decently new enough?
>

You should also have the iw tool which will provide all you need
using the nl80211 interface which is now the preferred interface.

> > You can still enable it (CFG80211_WEXT).
> > It has been disabled by:
> >
> > commit 24a0aa212ee2dbe44360288684478d76a8e20a0a
> > Author: Johannes Berg <johannes.berg@intel.com>
> > Date: Fri Nov 28 12:14:06 2014 +0100
> >
> > cfg80211: make WEXT compatibility unselectable
>
> I think this needs to be reverted.
>

\
 
 \ /
  Last update: 2014-12-30 21:41    [W:0.147 / U:0.332 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site