lkml.org 
[lkml]   [2014]   [Dec]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: iwlwifi-driver card doesn't work with 3.19-rc2+
Date
> 
> On 12/30/2014 09:23 AM, Emmanuel Grumbach wrote:
> > On Tue, Dec 30, 2014 at 3:33 PM, Jiri Kosina <jkosina@suse.cz> wrote:
> >>
> >> Hi,
> >>
> >> I just booted current Linus' tree (5faa0154fe33) on my x200s
> >> thinkpad, and wifi doesn't work. iwconfig is telling me that wlan0
> >> interface has no wireless extensions.
> >>
> >
> > So why do you used them?
> > They have been deprecated for a couple of years now. You should be
> > using nl80211 based tools such as iw.
>
> A couple of years is not very long where userspace is concerned.
>
Well - the decently new wireless tools do talk nl80211.
You can still enable it (CFG80211_WEXT).
It has been disabled by:

commit 24a0aa212ee2dbe44360288684478d76a8e20a0a
Author: Johannes Berg <johannes.berg@intel.com>
Date: Fri Nov 28 12:14:06 2014 +0100

cfg80211: make WEXT compatibility unselectable
\
 
 \ /
  Last update: 2014-12-30 16:01    [W:1.182 / U:0.008 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site